Tableaux dynamiques personnalisés

Voir le sujet précédent Voir le sujet suivant Aller en bas

Tableaux dynamiques personnalisés

Message  Bernard SUBRIN le Ven 29 Mai 2009 - 18:17

Pour ceux que ça intéresse, quand les formules de programmation et les liaisons entre classeurs sont trop sophistiquées, il est parfois nécessaire de fermer le classeur puis de le rouvrir pour que les bons résultats s'affichent
Est-ce dû à EXCEL ou à l'ordi pas assez puissant ?
avatar
Bernard SUBRIN

Nombre de messages : 638
Localisation : Le Breuil (Rhône) 270 m
Date d'inscription : 21/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Tableaux dynamiques personnalisés

Message  GRNcorbas69 le Sam 30 Mai 2009 - 9:25

je pense que c'est plutôt un pb excel (beug ou option cachée conduisant au calcul que dans des conditions données).
Dans excel il y a assez peu de beug mais il en existe quelques uns quand même.

J-Louis

GRNcorbas69
Admin

Nombre de messages : 362
Date d'inscription : 24/11/2005

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Tableaux dynamiques personnalisés

Message  Bernard SUBRIN le Sam 30 Mai 2009 - 17:21

En fait, il faut seulement enregistrer les changements pour qu'ils soient visible et donc il n'est plus nécessaire de fermer puis rouvrir le classeur
Je ne crois pas à un bog mais plutôt à une surcharge de travail même avec des classeurs de 25 Mo
Voici un exemple de formule multi-fonctions :

=SI('[1 - DS.xls]Tn'!EE36="";"";SI(ET(REFV!$D$2="TN";REFV!$F$2="TN");'[1 - DS.xls]Tn'!EE36;SI(ET(REFV!$D$2="TX";REFV!$F$2="TX");'[1 - DS.xls]Tx'!EE36;SI(ET(REFV!$D$2="TN";REFV!$F$2="TX");'[1 - DS.xls]Tx'!EE36;SI(ET(REFV!$D$2="TX";REFV!$F$2="TN");'[1 - DS.xls]Tn'!EE36;SI(REFV!$D$2="TM";'[1 - DS.xls]Tm'!EE36;SI(REFV!$D$2="A";'[1 - DS.xls]A'!EE36;"")))))))

ou bien dans le classeur "VARIATIONS":

=SI(AP13="";"";SI($A$747=1;AP379-AP12;SI($A$747=2;AP379-AP11;SI($A$747=3;AP379-AP10;SI($A$747=4;AP379-AP9;SI($A$747=5;AP379-AP8;SI($A$747=6;AP379-AP7)))))))

Les références externes sont très gourmandes en puissance de calcul !
avatar
Bernard SUBRIN

Nombre de messages : 638
Localisation : Le Breuil (Rhône) 270 m
Date d'inscription : 21/08/2008

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Tableaux dynamiques personnalisés

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum